Have you encountered the error “/usr/bin/pacman: unrecognized option ‘–color never’” while trying to install or update packages in your Arch Linux system?. This has been an error experienced by many users, especially those using pacaur AUR wrapper to manage system packages.

I got /usr/bin/pacman: unrecognized option ‘–color never’ error while trying to install minikube-bin on Arch:

---
==> Making package: minikube-bin 0.28.0-1 (Thu 05 Jul 2018 10:39:08 AM EAT)
==> WARNING: Skipping dependency checks.
==> Retrieving sources...
  -> Found minikube_0.28.0
==> WARNING: Skipping all source file integrity checks.
==> Extracting sources...
==> Sources are ready.
:: Building minikube-bin package(s)...
==> Making package: minikube-bin 0.28.0-1 (Thu 05 Jul 2018 10:39:08 AM EAT)
==> Checking runtime dependencies...
==> Installing missing dependencies...
/usr/bin/pacman: unrecognized option '--color never'
==> ERROR: 'pacman' failed to install missing dependencies.
:: failed to build minikube-bin package(
----

The fix for this is to enable colors when pacman’s output is on a tty. To do this, open pacman.conf file

$ sudo /etc/pacman.conf

Then uncomment the line # Color like below:

pacma enable color

This will allow pacaur to pass the option. Now try installing the package again with pacaur or package manager of your choice.

$ pacaur -S minikube-bin

It should be working now.

Your support is our everlasting motivation,
that cup of coffee is what keeps us going!


As we continue to grow, we would wish to reach and impact more people who visit and take advantage of the guides we have on our blog. This is a big task for us and we are so far extremely grateful for the kind people who have shown amazing support for our work over the time we have been online.

Thank You for your support as we work to give you the best of guides and articles. Click below to buy us a coffee.

LEAVE A REPLY

Please enter your comment!
Please enter your name here