I stand to accuse Centos 7 repositories for being outdated.I installed  mariadb for local development, when all of a sudden i decided to use full text mysql queries and it  turns out the mysql version i was using did not support it. mysql 5.5
The folks at tecmint were rather helpful
upgrade-mariadb-5-5-to-10-centos-rhel-debian-ubuntu
Still i had this issue:

[[email protected] shockwave]# mysql_upgrade

Version check failed. Got the following error when calling the 'mysql' command line client
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
FATAL ERROR: Upgrade failed

To solve it;make sure you use

[[email protected] shockwave]# mysql_upgrade -p
[[email protected] shockwave]# supplyyour password here

That’s all.